Back to overview
Resolved
Medad Library Service Outage (UAE)
Sep 3, 2026 at 2:50am UTC
Affected services
Medad Library Management
Resolved
Sep 3, 2026 at 2:50am UTC
We experienced a service outage affecting the MEDAD Library Management Systems.
The service has been restored. Our team is continuing to closely monitor the service to ensure stability and prevent any further disruption.
Affected services