Back to overview
Resolved
ILS Maintenance Notification
Jul 8, 2026 at 2:00pm UTC
–
Jul 8, 2026 at 7:00pm UTC
Affected services
Medad Library Management
Resolved
Jul 8, 2026 at 7:00pm UTC
Maintenance ended
Affected services
Created
Jul 8, 2026 at 2:00pm UTC
We are performing a scheduled maintenance upgrade to improve system reliability. Temporary service impact may occur during this maintenance window.
Tenants that have already been upgraded in previous maintenance windows will not be impacted.
Release notes are available at: https://docs.medad.com/books/medad-ils/page/medad-june-2026
Affected services